REDASH_STATSD_PORT and REDASH_STATSD_HOST don't seem to have any effect

Admittedly, I have an old install (1.0.3), but I can see that the variables are implemented in the code, they just don’t seem to have any effect when I put then in the .env file and restart redash? I’m trying to prevent redash from sending stats into my datadog instance and creating custom metrics that cost $$ unnecessarily.

Thoughts?

Are you certain the contents of your .env file are actually being loaded to the environment?

The .env has the postgres credentials. I’m not sure how it would work at all without reading those, right?

Agree. But maybe the environment didn’t update when you restarted Redash? If you change the DB password to be intentionally wrong, does Redash still work?

Yes, if I change the database password in the .env the redash dashboard fails to work on restart

Interesting! What if you straight override the value in settings.py and then rebuild / restart? Any change?

actually, now it seems to be working. Maybe I did it wrong before. I changed the REDASH_STATS_PORT, and it seems to be working better.
Do you know if there’s a setting to just disable the STATS all together rather than changing the port and have them get sent into oblivion?

I’m not sure. V1 is pretty old. But changing it to 0.0.0.0 should work. Or even a string that isn’t a valid IP address.