Relation "organizations" does not exist


#1

First time user setting up a trial Redash server at the request of a customer. My AWS admin used the AWS AMI and gave me the IP address. I get a login screen asking for an email and password?

Digging around I find that I was supposed to be prompted for the creation of an Admin u/p.

I was able to run this successfully (ssh as ubuntu):

sudo -u redash ./bin/run python manage.py users create --admin --password admin “Admin” “admin”

I then try to add a user via:
sudo -u redash ./manage.py users create test1(at)test(dot)com test1234

…relation “organizations” does not exist


#2

LINE 2: FROM organizations
^
[SQL: ‘SELECT organizations.updated_at AS organizations_updated_at, organizations.created_at AS organizations_created_at, organizations.id AS organizations_id, organizations.name AS organizations_name, organizations.slug AS organizations_slug, organizations.settings AS organizations_settings \nFROM organizations \nWHERE organizations.slug = %(slug_1)s \n LIMIT %(param_1)s’] [parameters: {‘slug_1’: u’default’, ‘param_1’: 1}]


#3

I tried to do this:
sudo -u redash ./bin/run python manage.py database create_tables

[2018-02-17 15:00:21,063][PID:5833][INFO][root] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
[2018-02-17 15:00:21,085][PID:5833][INFO][root] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt
[2018-02-17 15:00:21,308][PID:5833][INFO][root] Latest version: 3.0.0 (newer: True)
[2018-02-17 15:00:21,673][PID:5833][INFO][alembic(dot)runtime(dot)migration] Context impl PostgresqlImpl.
[2018-02-17 15:00:21,673][PID:5833][INFO][alembic(dot)runtime(dot)migration] Will assume transactional DDL.


#4

Same results. Not able to log in with email/password. Any suggestions here?

Thanks. Matt


#5

Problem solved. My admin pulled a head fake on me.