SAML login button is missing

Self hosted Redash 8 - SAML Button is missing on login, see attached image:

Weirdly enough this happens only on one host. Found this in redash_scheduled_worker_1:

[2021-05-28 12:47:25,748][PID:1][INFO][MainProcess] Connected to redis://redis:6379/0
[2021-05-28 12:47:25,785][PID:1][INFO][MainProcess] mingle: searching for neighbors
[2021-05-28 12:47:26,835][PID:1][INFO][MainProcess] mingle: sync with 1 nodes
[2021-05-28 12:47:26,835][PID:1][INFO][MainProcess] mingle: sync complete
[2021-05-28 12:47:26,871][PID:1][INFO][MainProcess] celery@54558f0caf56 ready.
[2021-05-28 12:47:28,810][PID:1][INFO][MainProcess] sync with celery@ebe7dbc7fc53
[2021-05-28 12:47:31,057][PID:1][WARNING][MainProcess] consumer: Connection to broker lost. Trying to re-establish the connection…
Traceback (most recent call last):
File “/usr/local/lib/python2.7/site-packages/celery/worker/consumer/consumer.py”, line 318, in start
blueprint.start(self)
File “/usr/local/lib/python2.7/site-packages/celery/bootsteps.py”, line 119, in start
step.start(parent)
File “/usr/local/lib/python2.7/site-packages/celery/worker/consumer/consumer.py”, line 596, in start
c.loop(*c.loop_args())
File “/usr/local/lib/python2.7/site-packages/celery/worker/loops.py”, line 91, in asynloop
next(loop)
File “/usr/local/lib/python2.7/site-packages/kombu/asynchronous/hub.py”, line 362, in create_loop
cb(*cbargs)
File “/usr/local/lib/python2.7/site-packages/kombu/transport/redis.py”, line 1052, in on_readable
self.cycle.on_readable(fileno)
File “/usr/local/lib/python2.7/site-packages/kombu/transport/redis.py”, line 348, in on_readable
chan.handlerstype
File “/usr/local/lib/python2.7/site-packages/kombu/transport/redis.py”, line 679, in _receive
ret.append(self._receive_one(c))
File “/usr/local/lib/python2.7/site-packages/kombu/transport/redis.py”, line 690, in _receive_one
response = c.parse_response()
File “/usr/local/lib/python2.7/site-packages/redis/client.py”, line 3036, in parse_response
return self._execute(connection, connection.read_response)
File “/usr/local/lib/python2.7/site-packages/redis/client.py”, line 3013, in _execute
return command(*args)
File “/usr/local/lib/python2.7/site-packages/redis/connection.py”, line 637, in read_response
response = self._parser.read_response()
File “/usr/local/lib/python2.7/site-packages/redis/connection.py”, line 290, in read_response
response = self._buffer.readline()
File “/usr/local/lib/python2.7/site-packages/redis/connection.py”, line 224, in readline
self._read_from_socket()
File “/usr/local/lib/python2.7/site-packages/redis/connection.py”, line 199, in _read_from_socket
(e.args,))
ConnectionError: Error while reading from socket: (u’Connection closed by server.’,)
[2021-05-28 12:47:32,127][PID:1][INFO][MainProcess] Connected to redis://redis:6379/0
[2021-05-28 12:47:32,135][PID:1][INFO][MainProcess] mingle: searching for neighbors
[2021-05-28 12:47:33,145][PID:1][INFO][MainProcess] mingle: all alone
[2021-05-28 12:47:34,426][PID:1][INFO][MainProcess] sync with celery@4ca4f75b9499

Any ideas here? Really need help

Have you bounced your containers? The error in your logs isn’t specific to SAML. Looks like your Redis container crashed.

Did do bounce all of the containers and instance itself, just in case. Issue is still there.

Here is logs from Redis container:

1:C 27 May 2021 13:10:04.551 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo

1:C 27 May 2021 13:10:04.553 # Redis version=5.0.6, bits=64, commit=00000000, modified=0, pid=1, just started

1:C 27 May 2021 13:10:04.553 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf

1:M 27 May 2021 13:10:04.558 * Running mode=standalone, port=6379.

1:M 27 May 2021 13:10:04.558 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.

1:M 27 May 2021 13:10:04.558 # Server initialized

1:M 27 May 2021 13:10:04.558 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.

1:M 27 May 2021 13:10:04.558 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.

1:M 27 May 2021 13:10:04.559 * DB loaded from disk: 0.001 seconds

1:M 27 May 2021 13:10:04.559 * Ready to accept connections

1:M 27 May 2021 13:15:05.018 * 100 changes in 300 seconds. Saving…

1:M 27 May 2021 13:15:05.019 * Background saving started by pid 14

14:C 27 May 2021 13:15:05.024 * DB saved on disk

14:C 27 May 2021 13:15:05.024 * RDB: 0 MB of memory used by copy-on-write

1:M 27 May 2021 13:15:05.119 * Background saving terminated with success

1:M 27 May 2021 13:20:06.026 * 100 changes in 300 seconds. Saving…

1:M 27 May 2021 13:20:06.026 * Background saving started by pid 15

15:C 27 May 2021 13:20:06.032 * DB saved on disk

Any other suggestions? Issue is still there. I’m not sure how to solve it.

I am having the same problem. Any troubleshooting ideas?