SAML login does not redirect user to next target

Issue Summary

When logging in with SAML, the ?next= parameter is not used to redirect the user following successful authentication. I suspect this is to do with the strict URL redirection that occurs during SAML auth and that to work around this, we’d have to move/duplicate the redirection to a cookie value.

Technical details:

  • Redash Version: Version: 10.1.0 (2589bef1)
  • Browser/OS: All
  • How did you install Redash: Kubernetes
1 Like

Thanks for reporting this. I agree that a cookie approach is the best option. Although I’m surprised to see this happening for you. I wonder if it’s a regression from the previous version…