Setup page after restart Redash using Docker

When i install redash, i see a setup page. When machine reboots and docker restarts, i see setup page again. Is any way to configure redash to setup only once and be automatically login after reboot machine?

Are you sure you ran all the steps during setup? It sounds like your settings weren’t persisted to the database. Specifically, did you run:

docker-compose run --rm server create_db

Yes, i’am starting service like systemd service. So i write
ExecStartPre=/usr/local/bin/docker-compose run --rm server create_db

and

ExecStart=/usr/local/bin/docker-compose up

and every start i get a setup page

Maybe i do something wrong, help me please!

Ha, that would do it! This command should only be run once.

docker-compose run --rm server create_db

If you rerun it every time you start the server then it will blow away the old data :wink:

So, how i should change my service script to start redash correctly? Use only ExecStart=/usr/local/bin/docker-compose up? I tried this way, but get sqlalchemy.exc.programmingerror on start up.

Maybe there was an error while starting postgres container, but i don’t how to check it

I would manually run the create_db command once. Then only use docker-compose up -d in your service command.

So, i done create_db command once while installing and setting redash, then after rebooting my machine, i done docker-compose up -d and got an error

LINE 2: FROM organizations 
             ^

[SQL: SELECT organizations.updated_at AS organizations_updated_at, organizations.created_at AS organizations_created_at, organizations.id AS organizations_id, organizations.name AS organizations_name, organizations.slug AS organizations_slug, organizations.settings AS organizations_settings 
FROM organizations 
WHERE organizations.slug = %(slug_1)s 
 LIMIT %(param_1)s]
[parameters: {'slug_1': 'default', 'param_1': 1}]
(Background on this error at: http://sqlalche.me/e/f405)```

solved by install the latest version of Node.js

1 Like