Unable to connect datasource after redash upgrade from V5.0.2 to V7.0

Issue Summary

unable to connect datasource after redash upgrade from V5.0.2 to V7.0

A summary of the issue and the browser/OS environment in which it occurs.
I had upgrade current redash version 5.0.2 to V7.
I’m getting error while trying same datasource connection which is working fine in backup old redash (V5.0.2).
Error - _init() got an unexpected keyword argument ‘protocol’

Technical details:

  • Redash Version: V7.0
  • Browser/OS: Ubuntu
  • How did you install Redash: Amazon ec2 image (ami-0d915a031cabac0e0))