Issue Summary

Trying to connect to Redash after using an AMI on AWS times out with “504 Gateway Time-out” from nginx

Technical details:

  • Redash Version: 5.0.1
  • Browser/OS: Version 69.0.3497.100 (Official Build) (64-bit)
  • How did you install Redash: I used AMI: ami-0b1f24678e41d08f2 on us-east-1. Upon launch I enabled SSH on port 22, HTTP on port 80, HTTPS on port 443 for all incoming traffic. Later I also enabled port 5000 just to check. When I visit the public ip, I get the time-out message after a long while. I am able to ssh and see gunicorn processes running on Nginx is also running.

The CPU utilizations go up when I visit the ip, so the request does reach the server.

Was a resource starvation, upgrade worked.