Unable to create docker based development environment

Unable to create docker based development environment based on the https://redash.io/help/open-source/dev-guide/docker documentation.

For some reason the Postgres isn’t accessible in the following step

docker-compose run --rm server create_db

It fails with the following error (tested two separate Windows 10 based dev PCs and both face the issue)

sqlalchemy.exc.OperationalError: (psycopg2.OperationalError) could not translate host name "postgres" to address: Name or service not known

What could be causing the issue here?

I get a similar error on the same step of the guide:

sqlalchemy.exc.OperationalError: (psycopg2.OperationalError) could not translate host name “postgres” to address: No address associated with hostname

1 Like

The problem is due to a breaking change in PostgreSQL.
Probably there is a better solution, but atm I’ve solved by editing the “docker-compose.yml” file adding the environment part:

  ...
  postgres:
    image: postgres:9.5-alpine
    ...
    restart: unless-stopped
    environment:
      POSTGRES_HOST_AUTH_METHOD: "trust"
  email:
  ...

So that command goes forward.

But continuing with the setup steps, the “npm run build” command gives ELIFECYCLE errors, “rm” is not recognized as a command, the “postgres_1” messages keep emitting a “LOG: unexpected EOF on client connection with an open transaction” messages, and in the end when I try to launch “http://localhost:5000”, I get the setup page only with its HTML, no CSS and no images. And even if I try to fill the form in this broken page, it goes to a Chrome’s ERR_CONNECTION_REFUSED page, then eventually refreshing it becomes a Werkzeug’s “dontpanic” output, saying:

FileNotFoundError: [Errno 2] No such file or directory: ‘/app/redash/settings/…/…/client/dist/index.html’

For me it was enough just to add that and the build started to succeed after that.

I have the same problem. Do you have solved the problem?

I’m sorry to say no :pensive:

I seem to know how to avoid this proble.
Use this url to get redash resource bundle. Extract resource package and enter into the folder of “redash” and execute command of “docker-compose -f docker-compose.yml run --rm server create_db”.

url: https://version.redash.io/API/releases
execute command:wget https://s3.amazonaws.com/redash-releases/redash.7.0.0.b17535.tar.gz

Thanks. I’m not sure if I’ll try this because meanwhile I’ve chosen a radically different solution and by now I’m in that path.

ok! I’m in this path.
If you have Installed successfully,can you tell me and share the way with me?
Thank you!

No - I meant I gave up on trying Redash and moved on with something else. Sorry for not being able to help.

Ok!
I have installed successfully.
You can have a try If you want use redash.

This is fixed in: