Unable to start redash server

Issue Summary

I am trying to installing self hosted redash with all the components separately via docker. Have successfully installed redis and Postgres on different container on different hosts.

However while running redash server container via docker, we are getting segment fault error. We have ~6GB memory on this host and have verified the connectivity with the other node, where redis and postgers are running. Have tried to enable debug to find the root cause, but still invain. We tried with various commands “server/dev_server/create_db/debug”, but nothing helps. Could we please help to resolve the issue.

docker run --rm -e REDASH_LOG_LEVEL=$REDASH_LOG_LEVEL -e REDASH_REDIS_URL=$REDASH_REDIS_URL -e REDASH_DATABASE_URL=$REDASH_DATABASE_URL -e REDASH_LOG_STDOUT=$REDASH_LOG_STDOUT -it -p5000:5000 redash/redash create_db
[2019-08-31 10:38:15,472][PID:115][DEBUG][root] Creating Redis connection (redis://10.xx.xx.xx:6379/0)
[2019-08-31 10:38:15,521][PID:115][DEBUG][redash.query_runner] Registering Amazon Athena (athena) query runner.
[2019-08-31 10:38:15,598][PID:115][DEBUG][redash.query_runner] Registering BigQuery (bigquery) query runner.
[2019-08-31 10:38:15,611][PID:115][DEBUG][redash.query_runner] Registering GoogleSpreadsheet (google_spreadsheets) query runner.
[2019-08-31 10:38:15,611][PID:115][DEBUG][redash.query_runner] Registering Graphite (graphite) query runner.
[2019-08-31 10:38:15,650][PID:115][DEBUG][redash.query_runner] Registering MongoDB (mongodb) query runner.
[2019-08-31 10:38:15,653][PID:115][DEBUG][redash.query_runner] Registering MySQL (mysql) query runner.
[2019-08-31 10:38:15,654][PID:115][DEBUG][redash.query_runner] Registering MySQL (Amazon RDS) (rds_mysql) query runner.
[2019-08-31 10:38:15,663][PID:115][DEBUG][redash.query_runner] Registering PostgreSQL (pg) query runner.
[2019-08-31 10:38:15,663][PID:115][DEBUG][redash.query_runner] Registering Redshift (redshift) query runner.
[2019-08-31 10:38:15,663][PID:115][DEBUG][redash.query_runner] Registering CockroachDB (cockroach) query runner.
[2019-08-31 10:38:15,663][PID:115][DEBUG][redash.query_runner] Registering Url (url) query runner.
Segmentation fault (core dumped)

Technical details:

  • Redash Version: latest docker image
  • Base OS: Centos 7
  • How did you install Redash:

Welcome to the forum. That is an odd error. It suggests a recursive loop somewhere. A few questions:

  1. When you run the server does it always crash while initiating the URL data source?
  2. The URL Query runner is about as generic as they come. It’s also going to be deprecated. I wonder if disabling it in your Python source will fix the issue.

I think @justinclift runs Redash on CentOS too. Perhaps he can provide some input.

This could be an OS-level issue related to how big of a stack is allocated per-process (see this SO link). We develop against Ubuntu, not CentOS. And stack-allocation could be quite different between the two.