Upgrading from 4-> 7 and lost all queries and dashboards

Hello,

I recently backed up postgres per the documentation and then tried to upgrade to version 7 (latest). Upgrade went fine, brand new instance up and running.

However when i tried to import the posrtgres backup, it seemed to be successful but nothing is showing up in the UI.

I put the server down and backup, tried everything I can, but all my work is gone :(.

Does 4 not upgrade straight to 7?
Can I revert back to 4 and see all my stuff?

Please help, we had months of work here and I fear I have lost it all.

Hi,

Sorry about your experience. To be able to help you, I will need to know what are the steps you took when upgrading?

Thanks.

Forgot to mention: running v4 with the old DB should just work and anyway as long as you have your database backup, nothing is lost.

Hi,

No worries, I’m sure I just missed a step :).

  1. I backed up all of postgres
  2. I made a copy of the /opt/redash directory
  3. I did the docker method documented to upgrade with migration
  4. New version up and running asking for all of the initial startup items.
  5. I did the postgres injest of the .sql pg_dump created, did the down/up, still at #4

To your second reply, how do i go about just running v4 again while working on getting v7 to work with all of the original queries/dashboards?

Also, the first attempt I did was using the upgrade script via ‘sudo bin/upgrade’. Then i ran into other issues though so I ended up going with the docker upgrade method.

Update - box is now officially mucked up from trying to go back and forth so trying to get a new clean instance and start there.

Is it safe to install vesion 4.0.2 from src so that I can at least give my team a working instance again with their old queries?

That said, would be huge to learn how to then install 7 on another server and be able to use this postgres exported file i have to get those up and running on the latest.

Thanks @arikfr!

By default, the Docker setup uses the postgres database. Maybe the dump file created a new database nnamed redash, and hence why it tried to setup from scratch?

If this is the case, you need to either update the configuration to use this database or update the load process to use the postgres db. Once you done either one, do the migration process.

Probably Python dependencies issues, but it’s actually better to switch to the Docker based setup. Another option for you is to keep the same Postgres and Redis services on the host machine and only use Docker for the Redash processes.

So @arikfr is the process

  1. Stand up version 7 box
  2. ingest the .sql from the version 4 export into the postgres instance running within docker
  3. update the docker instance to use the “redash” database
  4. docker-compose run --rm server manage db upgrade

Or per the below link do I do step 4 first then steps 2 and 3?