URL Source from behind a corporate firewall


#1

Hi There,

I just worked out that to use a URL source you put the http://a.hostname.com.au in the source and then the trailing URI </blah/foo/do?something&that&is&interesting> in the first line of the query editor.

However, now I get the dreaded red banner stating:


Error running query: HTTPConnectionPool(host=‘a.hostname.com.au’, port=80): Max retries exceeded with url: /blah/foo/do?something&that&is&interesting (Caused by NewConnectionError(’<requests.packages.urllib3.connection.HTTPConnection object at 0x7fa15cb9c550>: Failed to establish a new connection: [Errno 111] Connection refused’,))


Running the same thing using curl on the server account gets a similar error…so blocked by corporate proxy.

No problem. I add the following to my Ubuntu etc/profile

export http_proxy=http://my.corporate.proxy.com.au:3128

great - now curl works for the call from cli… but ReDash queries are still blocked.

Question: Where is the “redash_proxy=someValue” configuration?

Is there a proxy configuration for Redash…or do you have to embed the proxy export statement within the Supervisor wrapper that get called within instantiation of the service…or is there another way,

I am scratching my head a little - any guidance gladly appreciated.

=========
Brief update
As a way to run redash via a proxy I tried adding “export http_proxy= xxxxx” into /etc/environment
No joy unfortunately. Will keep trying.