Web server: bin/run ./manage.py runserver --debugger --reload

#1

[root@myOS redash-6.0.0]# bin/run ./manage.py runserver --debugger --reload
sed: can’t read .env: No such file or directory
Traceback (most recent call last):
File “/home/develop/redash-6.0.0/manage.py”, line 6, in
from redash.cli import manager
File “/home/develop/redash-6.0.0/redash/init.py”, line 71, in
import_query_runners(settings.QUERY_RUNNERS)
File “/home/develop/redash-6.0.0/redash/query_runner/init.py”, line 267, in import_query_runners
import(runner_import)
File “/home/develop/redash-6.0.0/redash/query_runner/mapd.py”, line 4, in
import pymapd
File “/usr/lib/python2.7/site-packages/pymapd/init.py”, line 19, in
from .connection import ( # noqa
File “/usr/lib/python2.7/site-packages/pymapd/connection.py”, line 168
raise err from e
^
SyntaxError: invalid syntax

when i use “bin/run ./manage.py runserver --debugger --reload” to run web server ,It has been reported wrong. who have the same problem? help me
thank!!!

0 Likes

#2

This problem has been bothering me for a long time.help me thanks!

0 Likes

#3

You should pay attention to the error messages:

sed: can’t read .env: No such file or directory

I assume you don’t have a .env file in this folder?

0 Likes

#4

First of all, thank you for your timely reply. In the “For development, in most cases the default configuration is enough. But if you need to adjust the database configuration, mail settings or any other setting, you do so with environment variables.” Now I added the .env file,such as "export REDASH_LOG_LEVEL=“INFO”
export REDASH_REDIS_URL=redis://localhost:6379/0
export REDASH_DATABASE_URL=“postgresql:///redash”
export REDASH_COOKIE_SECRET=fsdfds
export REDASH_MAIL_SERVER=“localhost”
export REDASH_MAIL_PORT=“25”
export REDASH_MAIL_USE_TLS=false
export REDASH_MAIL_USE_SSL=false # default: False
export REDASH_MAIL_USERNAME=“None” # default: None
export REDASH_MAIL_PASSWORD=“None” # default: None
export REDASH_MAIL_DEFAULT_SENDER=“someemail” # Email address to send from
~

But The same mistake has not been resolved
[root@myOS redash-6.0.0]# bin/run ./manage.py check_settings
Traceback (most recent call last):
File “/home/develop/redash-6.0.0/manage.py”, line 6, in
from redash.cli import manager
File “/home/develop/redash-6.0.0/redash/init.py”, line 71, in
import_query_runners(settings.QUERY_RUNNERS)
File “/home/develop/redash-6.0.0/redash/query_runner/init.py”, line 267, in import_query_runners
import(runner_import)
File “/home/develop/redash-6.0.0/redash/query_runner/mapd.py”, line 4, in
import pymapd
File “/usr/lib/python2.7/site-packages/pymapd/init.py”, line 19, in
from .connection import ( # noqa
File “/usr/lib/python2.7/site-packages/pymapd/connection.py”, line 168
raise err from e
^
SyntaxError: invalid syntax

0 Likes

#5

Thanks Thanks for your help, But the problem remains unsolved.

0 Likes

#6

During the installation of Redash with Docker, the same error was reported when I started with Dokcer-compose up

0 Likes

#7

Did you try pulling latest version of the code? I think you’re using a version of pymapd that supports Python 3 only.

0 Likes

#8

Thank you very much. According to your prompt, I solved my problem. Thank you very much.

0 Likes

#9

Thank you very much. According to your prompt, I solved my problem. Thank you very much.

0 Likes