What's the recommended PostgreSQL engine version for Redash?

I astonishingly discovered that I’m still using 9.6.18 :scream_cat:
Can I upgrade it to 12.4?