You do not have permission to view the requested page


#1

Hi, guys!

I’m trying to configure a redash server for backend which is accessed by a proxy server. So, I have the Redash server running on port 3001 and I have another server with nginx “proxying” everything to my Redash server. The problem is, when I access the main page, this message is displayed to me: “You do not have permission to view the requested page.”, and the page is all white with some redash links. What could this be?


#2

Can you share a screenshot of this?


#3

Sure. Here it is!


#4

Can you try posting it again? For some reason it doesn’t load.


#5

Sure, here it is!


#6

It looks like the Javascript code is being loaded and you get rendering of the “raw” template. I would check your proxying configuration to make sure everything is being loaded properly.


#7

Today I’m doing this.

server {
    listen       80;
    server_name  <REDASH DOMAIN>;
    access_log   /var/log/nginx/redash.access.log;
    error_log  	 /var/log/nginx/redash.eou.io.error.log;

    location / {
      proxy_pass      http://<REDASH SERVER>:3001;
    }
  }

Do you have any sugestion about what is the best way to proxy the static content? I have ajusted the .env file, the REDASH_STATIC_ASSETS_PATH variable, but I’m not sure. What you think?


#8

I solved the problem. I used the NGINX config file from your github and works like a charm!


#9

Not be on the tail end of the dog here. I have this exact issue with the Bitnami VM, it looks like it’s not allowing external access. I have tried to search for these files but it looks like it’s not using NGINX. Please assist me in what I need to change because I am obtaining the same error as shown in the picture above.