Can't find mysql type while adding data source

There’s no mysql option in drop-down menu.

version: 9.0.0-alpha

How did you install Redash? It looks like you haven’t installed the dependencies that the MySQL data source needs.

I followed this document except using python3.
https://redash.io/help/open-source/dev-guide/setup

And how to install those dependencies plugins. I can’t find ANY documents about it.

Thanks.

First, I don’t recommend using the V9 alpha if you haven’t set up Redash before. There are big changes in play right now (migration to Py3, migration to React, migration to RQ from celery).

Use V8:

  • It’s stable
  • It’s easy to set up
  • It came out last week

On the page you linked:

Python Packages

For development the minimum required packages to install are described in:

  • requirements.txt
  • requirements_dev.txt

You install them with pip:

pip install -r requirements.txt -r requirements_dev.txt
pip install -r requirements.txt -r requirements_dev.txt

It is described in the link I mention therefor I have already tried this but still in vain…

It seems related to this: Can't find data source which been added to query_runners when upgrade to V8

Any idea ? Appreciate any help thanks.

I’ll try to reproduce this so I can give you better debugging steps.

Try adding one more requirements file:

pip install -r requirements_all_ds.txt