Update to version 8.0.0.0

Well, it LOOKS like it’s upgraded - but it doesn’t. Worked OK during last upgrade. Using official Redash Docker image on AWS.

Did a reboot and everything, but my dashboard still says 7.0.0+b18042

Very often fails to restart after update and needs a reboot.

ubuntu@ip-xx-xx-xx:/opt/redash$ sudo docker-compose stop server scheduler scheduled_worker adhoc_worker
Stopping redash_scheduled_worker_1 ... done
Stopping redash_scheduler_1        ... done
Stopping redash_adhoc_worker_1     ... done
Stopping redash_server_1           ... done
ubuntu@ip-xx-xx-xx:/opt/redash$ sudo docker-compose run --rm server manage db upgrade
Starting redash_redis_1    ... done
Starting redash_postgres_1 ... done
[2019-11-13 17:50:45,983][PID:1][INFO][root] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
[2019-11-13 17:50:46,007][PID:1][INFO][root] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt
[2019-11-13 17:50:47,898][PID:1][INFO][root] Latest version: 8.0.0 (newer: True)
[2019-11-13 17:50:48,512][PID:1][INFO][alembic.runtime.migration] Context impl PostgresqlImpl.
[2019-11-13 17:50:48,513][PID:1][INFO][alembic.runtime.migration] Will assume transactional DDL.
ubuntu@ip-xx-xx-xx:/opt/redash$ sudo docker-compose up -d
redash_redis_1 is up-to-date
redash_postgres_1 is up-to-date
Starting redash_scheduled_worker_1 ... done
Starting redash_adhoc_worker_1     ... done
Starting redash_server_1           ... done
Starting redash_scheduler_1        ... done
redash_nginx_1 is up-to-date
ubuntu@ip-xx-xx-xx:/opt/redash$ sudo service supervisor restart all

docker-compose.yml

ersion: '2'
x-redash-service: &redash-service
  image: redash/redash:latest
  depends_on:
    - postgres
    - redis
  env_file: /opt/redash/env
  restart: always
services:
  server:
    <<: *redash-service
    command: server
    ports:
      - "5000:5000"
    environment:
      REDASH_WEB_WORKERS: 4
  scheduler:
    <<: *redash-service
    command: scheduler
    environment:
      QUEUES: "celery"
      WORKERS_COUNT: 1
  scheduled_worker:
    <<: *redash-service
    command: worker
    environment:
      QUEUES: "scheduled_queries"
      WORKERS_COUNT: 1
  adhoc_worker:
    <<: *redash-service
    command: worker
    environment:
      QUEUES: "queries"
      WORKERS_COUNT: 2
  redis:
    image: redis:3.0-alpine
    restart: always
  postgres:
    image: postgres:9.5.6-alpine
    env_file: /opt/redash/env
    volumes:
      - /opt/redash/postgres-data:/var/lib/postgresql/data
    restart: always
  nginx:
    image: redash/nginx:latest
    ports:
      - "80:80"
    depends_on:
      - server
    links:
      - server:redash
    restart: always

Can you provide access to AMI with redash:7.0.0.b18042? I checked from AWS and could find only 5 and 8

There wasn’t one. By images I was referring to Docker images.

Roger, then I take AMI with 5 and upgrade to 7 via 6, replace DB and upgrade to 8?

Or build 7 from scratch on clean machine

Is there a third option? Could I build my own tarball? And if so how would I do that… I assume you used to do that every time from ver1 to 7.

Ok so Ive been testing out how to do this and I cant seem to get it to work. I tried for somthing close to the first option by trying to create a local vm to test it all out. I wont be bulding on a It’s a new ubuntu 18 instalation with nothing else on it.

I created the vm and copied the setup.sh file to the server. I edited the setup.sh to commented out
“sudo docker-compose run --rm server create_db
sudo docker-compose up -d”
I then ran the setup.sh and it all seemd to work. I edited the docker-compose.yml and changed redash:8.0.0.b32245 to redash:7.0.0.b18042.
I ran the docker-compose commands above to start the v7 instance.
Next I stoped all the docker containers and only restarted the redash_postgres_1 container.

So now I can import my old db, to do this I did the following:
sudo docker exec -i redash_postgres_1 dropdb postgres -U postgres
sudo docker exec -i redash_postgres_1 createdb postgres --owner=postgres -U postgres
sudo docker exec -i redash_postgres_1 psql -d postgres -U postgres < ~/backup.sql

I stoped the redash_postgres_1 container and restarted them all: sudo docker-compose up -d

I should now have a v7 docker running with my data from my non docker system. I can now acccess the server in the browser and my dashboard are there (but not working) but none of my queries will open. The queries are listed but when I click on them I get " It seems like we encountered an error. Try refreshing this page or contact your administrator."

My datasources are also missing so I tried to add them again - no joy. When I try and add a datasource (MySQL) I get a mesage telling me that a datasource with that name already exists. No matter what name I use I get the same error.

What am I doing wrong?

I cant upgrade to 8 till I get the docker working on 7 with my non docker data. I now understand a lot mor about dockers (but i still hate them).

I faced a similar phenomenon. Upon investigation, i found that the version checking API did not include the URL of the file for the update.
I think the reason why the error occurs is that there is no download URL of the file for update version8, so it is not possible to pass appropriate variables to wget in the update program.
The api url is below.
https://version.redash.io/api/releases?channel=

I gave up in the end. Did a clean install of the docker version on a new cloud server and manually rebuilt all the queries, dashboards and readded all the users and data sources. Took me about 36 hours. Not fun… Also had to explain to all the users.