Where to Start and How to install redash in my local laptop windows 10

Hi ,

I am new to redash…I dont know how to launch or run code from below URL.

Any documentation mention step by step installations ??

The docs are pretty straightforward. What have you tried so far? What didn’t work?

Thanks for replying quick…I am very new beginner and work basically in .Net applications.I see redash as interesting open source to visualize data.So i would like to try it.But not sure where to start …Will it works on windows 10 and windows server 2012? Thanks for your answer.

Your best bet is to use Docker for this. Check out the docker development steps to get a proof of concept going.

Basically you’ll clone the repository and run docker-compose up -d

Tried it…some error…Please help on this

now i have progress but dont know what is below line not implemented

Hi Further i noticed below error :slight_smile:
Any clue on this .

Hi ,

I have resolved all above errors: but finally struck up .

How to solve this . please help freinds…i already struck up

Hi Mubarak, it’s finally business hours in the US again. What steps have you followed so far? What errors do you see?

Hi Jesse ,

THanks for your email.

  1. I took code from below. Downloaded Zip.

  1. Below command

  1. Then below command

  1. Now i am not able execute below database scripts , below command

What do you see after you run docker-compose up -d?

Did the containers start? You can check this by running docker-compose ps.

You should see something like this:

                Name                              Command               State                     Ports                  
redash-master_adhoc_worker_1       /app/bin/docker-entrypoint ...   Up      5000/tcp                                 
redash-master_nginx_1              nginx -g daemon off;             Up      443/tcp,>80/tcp,:::80->80/tcp
redash-master_postgres_1           docker-entrypoint.sh postgres    Up      5432/tcp                                 
redash-master_redis_1              docker-entrypoint.sh redis ...   Up      6379/tcp                                 
redash-master_scheduled_worker_1   /app/bin/docker-entrypoint ...   Up      5000/tcp                                 
redash-master_scheduler_1          /app/bin/docker-entrypoint ...   Up      5000/tcp                                 
redash-master_server_1             /app/bin/docker-entrypoint ...   Up>5000/tcp,:::5000->5000/tcp 
redash-master_worker_1             /app/bin/docker-entrypoint ...   Up      5000/tcp  

Hi Jesse ,

Please find below screen print please…

Your screenshots are all cut-off. Please post a full screenshot or copy the text and paste it directly. Based on the last snippet you shared it doesn’t look like any containers are running. But that might be because you cropped out all the relevant data.

Hi Jesse ,

Here it is.

Thank you. What about the output from docker-compose ps? It seems like Redash hasn’t started.

Hi Jesse ,

Here it is complete snap.

Yes the problem here is that your containers didn’t start.

Please run docker-compose up and examine the output. What errors do you see?

Jesse ,

I changed docker setting switch to linux container. I see now some output with docker-compose up…the command running for last few mins and output is here.
Please help on this.

That’s good progress. The containers started. Now you need to run docker-compose run --rm server create_db.

Jesse ,

That one is picked up. yarn build error now.

Thanks for your help ahead !